PTC MKS Toolkit Menu

PTC MKS Toolkit Customer Support - Supported Versions

PTC X/Server

Security Vulnerability Responses

CVE-2014-6271 Security Vulnerability Does Not Impact PTC MKS Toolkit
PTC MKS Toolkit has a shell called BASH; however, it is our own KornShell with some BASH features implemented based on what the man page says those features do. It shares no code with the affected GPL version. In fact, reading function definitions from the environment is not one of those features.

PTC MKS Toolkit is not affected by this vulnerability.


CVE-2014-0160 Security Vulnerability – Bug in OpenSSL’s implementation of the TLS/DTLS (transport layer security protocols)/OpenSSL 1.0.1 to 1.01f (inclusive) PTC MKS Toolkit versions 9.5 and 9.6 include a version of OpenSSL that contains the above vulnerability. We have confirmed that our ssh.exe is not impacted, but three areas of risk have been identified:

  • Use of web.exe/netnews.exe could expose information to a compromised server.
  • Use of the openssl.exe s_client and s_server commands could expose information to a remote machine.
  • NutCracker ported applications that are linked against the OpenSSL libraries.
Hotfixes are now available for PTC MKS Toolkit versions 9.5 and 9.6 that will disable the TLS/DTLS (transport layer security protocols) heartbeat extension and fully address this vulnerability.

Please contact PTC MKS Toolkit Technical Support (mkstoolkitsupport@ptc.com) to obtain a copy.

NOTE: PTC X/Server, MKS Toolkit versions 9.4 and earlier are not impacted by this vulnerability.

The following tables outline the versions of our products that are supported, and if applicable, any patches for that product version. If your version is not listed, please contact PTC MKS Toolkit Sales for an update.

Note:
Upon announcement, support expiration dates for released versions of the PTC MKS Interoperability Products will be included in the tables below. This means that we will no longer patch or address issues found in a version with expired support. If an issue reported in a version with expired support can also be reproduced in a currently supported version of the software, the fix will be considered for inclusion in a supported version.

PTC MKS Toolkit for Developers

Version Support Expires Current Patch Platforms Certified OSs
9.6 TBA, released 06 March 2014 9.6 Patch 1 x86, IA64, AMD64 Windows 8.1, Windows 8, Windows Server 2012 R2, Windows Server 2012, Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista
9.5 Expires Q2 2015 (calendar) None x86, IA64, AMD64 Windows 8, Windows Server 2012, Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista
9.4 Expired 01 November 2014 9.4 Patch 1 x86, IA64, AMD64 Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista
9.3 Support Expired 14 May 2010 (early release of 9.4) None x86, IA64, AMD64 Windows 7, 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista
9.2 Support Expired 31 January 2013 9.2 Patch 3 x86, IA64, AMD64 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista
9.1 Support Expired 04 February 2010 9.1 Patch 1 x86, IA64, AMD64 2000, XP Home, XP Pro, Server 2003, Vista
9.0 Support Expired 10 July 2008 9.0 Patch 5 x86, IA64, AMD64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003
8.7 Support Expired 01 February 2007 8.7 Patch 5 x86, IA64, AMD64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003
8.6 Support Expired 01 June 2005 8.6 Patch 3 x86, IA64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003
8.5 Support Expired 01 Nov 2004 8.5 Patch 2 x86, IA64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003
8.1 Support Expired 30 Nov 2003 8.1 Patch 3 x86, IA64 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro
8.0 Support Expired 30 Sep 2003 8.0 Patch 1 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro
7.5 Support Expired 31 January 2003 7.5 Patch 1 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000
7.0.1 Support Expired 31 January 2002 none x86 Windows 9x, NT 4.0, NT 4.0 TSE, 2000
7.0 Support Expired 31 January 2002 7.0 Patch 1 x86 Windows 9x, NT 4.0, NT 4.0 TSE, 2000

PTC MKS Toolkit for Interoperability

Version Support Expires Current Patch Platforms Certified OSs
9.6 TBA, released 06 March 2014 9.6 Patch 1 x86, IA64, AMD64 Windows 8.1, Windows 8, Windows Server 2012 R2, Windows Server 2012, Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista
9.5 Expires Q2 2015 (calendar) None x86, IA64, AMD64 Windows 8, Windows Server 2012, Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista
9.4 Expired 01 November 2014 9.4 Patch 1 x86, IA64, AMD64 Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista
9.3 Support Expired 14 May 2010 (early release of 9.4) None x86, IA64, AMD64 Windows 7, 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista
9.2 Support Expired 31 January 2013 9.2 Patch 3 x86, IA64, AMD64 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista
9.1 Support Expired 04 February 2010 9.1 Patch 1 x86, IA64, AMD64 2000, XP Home, XP Pro, Server 2003, Vista
9.0 Support Expired 10 July 2008 9.0 Patch 5 x86, IA64, AMD64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003
8.7 Support Expired 01 February 2007 8.7 Patch 5 x86, IA64, AMD64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003
8.6 Support Expired 01 June 2005 8.6 Patch 3 x86, IA64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003
8.5 Support Expired 01 Nov 2004 8.5 Patch 2 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003
8.1 Support Expired 30 Nov 2003 8.1 Patch 3 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro
8.0 Support Expired 30 Sep 2003 8.0 Patch 1 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro
7.5 Support Expired 31 January 2003 7.5 Patch 1 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000
7.0.1 Support Expired 31 January 2002 none x86 Windows 9x, NT 4.0, NT 4.0 TSE, 2000
7.0 Support Expired 31 January 2002 7.0 Patch 1 x86 Windows 9x, NT 4.0, NT 4.0 TSE, 2000

PTC MKS Toolkit for Enterprise Developers

Version Support Expires Current Patch Platforms Certified OSs Certified Compilers
9.6 TBA, released 06 March 2014 9.6 Patch 1 x86, IA64, AMD64 Windows 8.1, Windows 8, Windows Server 2012 R2, Windows Server 2012, Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista MS VC++ 6.0, 7.0, 7.1, 8.0, 9.0, 10.0 or 11.0, MS SDK, VS.Net, VS.Net 2003, VS Express (2005 (requires PSDK or WSDK), 2008, 2010, 2012, 2013), MS C++ 2003 Toolkit (requires PSDK or WSDK), Intel C++ 8.x or 9.x (requires PSDK or WSDK), GCC 3.3.1 (Toolkit Resource kit), Absoft Fortran 5.x, 6.x, 7.x, 10.x, 13.0
9.5 Expires Q2 2015 (calendar) None x86, IA64, AMD64 Windows 8, Windows Server 2012, Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista MS VC++ 6.0, 7.0, 7.1, 8.0, 9.0, 10.0, MS SDK, VS.Net, VS.Net 2003, VS Express (2005 (requires PSDK or WSDK), 2008, 2010, 2012), MS C++ 2003 Toolkit (requires PSDK or WSDK), Intel C++ 8.x or 9.x (requires PSDK or WSDK), GCC 3.3.1 (Toolkit Resource kit), Absoft Fortran 5.x, 6.x, 7.x, 10.x 10.x, GCC, Intel C/C++ 8.0, 9.0
9.4 Expired 01 November 2014 9.4 Patch 1 x86, IA64, AMD64 Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista VC++ 5.x, 6.x, VS.Net, VS.Net 2003, VS 2005, VS 2008, VS 2010, Absoft Fortran 5.x, 6.x, 7.x, 10.x, GCC, Intel C/C++ 8.0, 9.0
9.3 Support Expired 14 May 2010 (early release of 9.4) None x86, IA64, AMD64 Windows 7, 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista VC++ 5.x, 6.x, VS.Net, VS.Net 2003, VS 2005, VS 2008, VS 2010, Absoft Fortran 5.x, 6.x, 7.x, 10.x, GCC, Intel C/C++ 8.0, 9.0
9.2 Support Expired 31 January 2013 9.2 Patch 3 x86, IA64, AMD64 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista VC++ 5.x, 6.x, VS.Net, VS.Net 2003, VS 2005, VS 2008, Absoft Fortran 5.x, 6.x, 7.x, 10.x, GCC, Intel C/C++ 8.0, 9.0
9.1 Support Expired 04 February 2010 9.1 Patch 1 x86, IA64, AMD64 2000, XP Home, XP Pro, Server 2003, Vista VC++ 5.x, 6.x, VS.Net, VS.Net 2003, VS 2005, Absoft Fortran 5.x, 6.x, 7.x, 10.x, GCC, Intel C/C++ 8.0, 9.0
9.0 Support Expired 10 July 2008 9.0 Patch 5 x86, IA64, AMD64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003 VC++ 5.x, 6.x, VS.Net, VS.Net 2003, VS 2005, Absoft Fortran 5.x, 6.x, 7.x, GCC, Intel C/C++ 8.0, 9.0
8.7 Support Expired 01 February 2007 8.7 Patch 5 x86, IA64, AMD64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003 VC++ 5.x, 6.x, VS.Net, VS.Net 2003, Absoft Fortran 5.x, 6.x, 7.x, GCC, Intel C/C++ 8.0
8.6 Support Expired 01 June 2005 8.6 Patch 3 x86, IA64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003 Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x, 7.x,
Visual Studio .NET
8.5 Support Expired 01 Nov 2004 8.5 Patch 2 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003 Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x, 7.x,
Visual Studio .NET
8.1 Support Expired 30 Nov 2003 8.1 Patch 3 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x, 7.x,
Visual Studio .NET
8.0 Support Expired 30 Sep 2003 8.0 Patch 1 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x, 7.x,
Visual Studio .NET
7.5 Support Expired 31 January 2003 7.5 Patch 1 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000 Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x, 7.x
7.0.1 Support Expired 31 January 2002 none x86 Windows 9x, NT 4.0, NT 4.0 TSE, 2000 Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x
7.0 Support Expired 31 January 2002 7.0 Patch 1 x86 Windows 9x, NT 4.0, NT 4.0 TSE, 2000 Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x

PTC X/Server

Please be advised that MKS X/Server 8.5 may experience the problem described below:

Microsoft released update 2506212 which contains a newer MFC42.dll. This DLL is incompatible with MKS X/Server 8.5.
The symptoms vary from the X/Server failing to start to the Windows Explorer hanging and freezing. We have reported this issue to Microsoft (case number SR111041558565991). We recommend that you first evaluate the value of this fix to your organization before deploying until Microsoft gives a definitive position on the nature of the problem and if you feel you need to deploy this fix for security reasons to also deploy our hot fixed dbserv.exe.

Problem Update ...

Microsoft has released a hot fix for this problem for Windows 7 and Windows Server 2008 R2 Operating Systems. The hot fix is available here : Security Update MS11-024 Hot Fix

Please contact PTC MKS Toolkit Customer Support to obtain the hotfix:
Email:MKSToolkitSupport@ptc.com
Phone: +1-703-803-7660.


Version Support Expires Current Patch Platforms Certified OSs
8.7 TBA, released 06 March 2014 8.7 Patch 1 x86, IA64, AMD64 Windows 8.1, Windows 8, Windows Server 2012 R2, Windows Server 2012, Windows 7, 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista
8.6 TBA, released 05 November 2012 None x86, IA64, AMD64 Windows 8, Windows Server 2012, Windows 7, 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista
8.5 Expired 01 November 2014 8.5 Patch 2 x86, IA64, AMD64 Windows 2000, XP, Server 2003, Server 2008, Vista, 7
8.2 Support Expired 30 April 2013 None x86, IA64, AMD64 Windows 2000, XP, Server 2003, Vista
8.1 Support Expired 01 February 2009 8.1 Patch 1 x86, IA64, AMD64 Windows 2000, XP, Server 2003, Vista
8.0 Support Expired 10 July 2008 None x86, IA64, AMD64 Windows 2000, XP, Server 2003, Vista RC2

MKS Lex & Yacc

Version Support Expires Current Patch Platforms Certified OSs
3.4† Support Expired 30 April 2013 3.4 Patch 1 x86, IA64, x64 Windows 8.1, Windows 8, Windows Server 2012 R2, Windows Server 2012, Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP, Server 2003, Vista
3.3.1 Support Expired 01 Jun 2005 none x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000
3.3 Support Expired 27 May 2004 none x86 Windows 9x, NT 4.0, NT 4.0 TSE, 2000
3.2a Support Expired 28 February 2001 none x86 Windows 9x, NT 4.0, NT 4.0 TSE

† Effective with the release of MKS Toolkit 9.5, we discontinued the sale and/or update of licenses of our MKS Lex & Yacc product. Going forward, MKS Lex & Yacc will be included with new versions of PTC MKS Toolkit for Developers and PTC MKS Toolkit for Interoperability. All MKS Lex & Yacc licenses with a current PCS support contract are eligible to be updated to PTC MKS Toolkit for Developers or PTC MKS Toolkit for Interoperability (depending on your environment) free of charge.

PTC MKS Toolkit for Professional Developers

Version Support Expires Current Patch Platforms Certified OSs Certified Compilers
9.6 TBA, released 06 March 2014 9.6 Patch 1 x86, IA64, AMD64 Windows 8.1, Windows 8, Windows Server 2012 R2, Windows Server 2012, Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista MS VC++ 6.0, 7.0, 7.1, 8.0, 9.0, 10.0 or 11.0, MS SDK, VS.Net, VS.Net 2003, VS Express (2005 (requires PSDK or WSDK), 2008, 2010, 2012, 2013), MS C++ 2003 Toolkit (requires PSDK or WSDK), Intel C++ 8.x or 9.x (requires PSDK or WSDK), GCC 3.3.1 (Toolkit Resource kit), Absoft Fortran 5.x, 6.x, 7.x, 10.x, 13.0
9.5 Expires Q2 2015 (calendar) None x86, IA64, AMD64 Windows 8, Windows Server 2012, Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista MS VC++ 6.0, 7.0, 7.1, 8.0, 9.0, 10.0, MS SDK, VS.Net, VS.Net 2003, VS Express (2005 (requires PSDK or WSDK), 2008, 2010, 2012), MS C++ 2003 Toolkit (requires PSDK or WSDK), Intel C++ 8.x or 9.x (requires PSDK or WSDK), GCC 3.3.1 (Toolkit Resource kit), Absoft Fortran 5.x, 6.x, 7.x, 10.x
9.4 Expired 01 November 2014 9.4 Patch 1 x86, IA64, AMD64 Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista VC++ 5.x, 6.x, VS.Net, VS.Net 2003, VS 2005, VS 2008, VS 2010, Absoft Fortran 5.x, 6.x, 7.x, 10.x, GCC, Intel C/C++ 8.0, 9.0
9.3 Support Expired 14 May 2010 (early release of 9.4) None x86, IA64, AMD64 Windows 7, 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista VC++ 5.x, 6.x, VS.Net, VS.Net 2003, VS 2005, VS 2008, VS 2010, Absoft Fortran 5.x, 6.x, 7.x, 10.x, GCC, Intel C/C++ 8.0, 9.0
9.2 Support Expired 31 January 2013 9.2 Patch 3 x86, IA64, AMD64 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista VC++ 5.x, 6.x, VS.Net, VS.Net 2003, VS 2005, VS 2008, Absoft Fortran 5.x, 6.x, 7.x, 10.x, GCC, Intel C/C++ 8.0, 9.0
9.1 Support Expired 04 February 2010 9.1 Patch 1 x86, IA64, AMD64 2000, XP Home, XP Pro, Server 2003, Vista VC++ 5.x, 6.x, VS.Net, VS.Net 2003, VS 2005, Absoft Fortran 5.x, 6.x, 7.x, 10.x, GCC, Intel C/C++ 8.0, 9.0
9.0 Support Expired 10 July 2008 9.0 Patch 5 x86, IA64, AMD64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003 VC++ 5.x, 6.x, VS.Net, VS.Net 2003, VS 2005, Absoft Fortran 5.x, 6.x, 7.x, GCC, Intel C/C++ 8.0, 9.0
8.7 Support Expired 01 February 2007 8.7 Patch 5 x86, IA64, AMD64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003 VC++ 5.x, 6.x, VS.Net, VS.Net 2003, Absoft Fortran 5.x, 6.x, 7.x, GCC, Intel C/C++ 8.0
8.6 Support Expired 01 June 2005 8.6 Patch 3 x86, IA64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003 Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x, 7.x,
Visual Studio .NET
8.5 Support Expired 01 Nov 2004 8.5 Patch 2 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003 Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x, 7.x,
Visual Studio .NET
8.1 Support Expired 30 Nov 2003 8.1 Patch 3 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x, 7.x,
Visual Studio .NET
8.0 Support Expired 30 Sep 2003 8.0 Patch 1 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x, 7.x,
Visual Studio .NET
7.5 Support Expired 31 January 2003 7.5 Patch 1 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000 Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x, 7.x
7.0.1 Support Expired 31 January 2002 none x86 Windows 9x, NT 4.0, NT 4.0 TSE, 2000 Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x
7.0 Support Expired 31 January 2002 7.0 Patch 1 x86 Windows 9x, NT 4.0, NT 4.0 TSE, 2000 Visual C++
5.x, 6.x,
Absoft Fortran
5.x, 6.x

PTC MKS Toolkit for Enterprise Developers 64-bit Edition

Version Support Expires Current Patch Platforms Certified OSs Certified Compilers
9.6 TBA, released 06 March 2014 9.6 Patch 1 x86, IA64, AMD64 Windows 8.1, Windows 8, Windows Server 2012 R2, Windows Server 2012, Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista MS VS 2005 (requires PSDK or WSDK), 2008 (Team Ed or WSDK for IA64), 2010 (Ultimate Ed or WSDK for IA64, MS PSDK or WSDK, 2012, 2013, Intel C++ 8.x or 9.x (requires PSDK or WSDK)
9.5 Expires Q2 2015 (calendar) None x86, IA64, AMD64 Windows 8, Windows Server 2012, Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista MS VS 2005 (requires PSDK or WSDK), 2008 (Team Ed or WSDK for IA64), 2010 (Ultimate Ed or WSDK for IA64, MS PSDK or WSDK, Intel C++ 8.x or 9.x (requires PSDK or WSDK)
9.4 Expired 01 November 2014 9.4 Patch 1 x86, IA64, AMD64 Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista MS SDK, Intel C/C++ 8.0, 9.0, Absoft 10.x
9.3 Support Expired 14 May 2010 (early release of 9.4) None x86, IA64, AMD64 Windows 7, 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista MS SDK, Intel C/C++ 8.0, 9.0, Absoft 10.x
9.2 Support Expired 31 January 2013 9.2 Patch 3 x86, IA64, AMD64 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista MS SDK, Intel C/C++ 8.0, 9.0, Absoft 10.x
9.1 Support Expired 04 February 2010 9.1 Patch 1 x86, IA64, AMD64 2000, XP Home, XP Pro, Server 2003, Vista MS SDK, Intel C/C++ 8.0, 9.0, Absoft 10.x
9.0 Support Expired 10 July 2008 9.0 Patch 5 x86, IA64, AMD64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003 MS SDK, Intel C/C++ 8.0, 9.0
8.7 Support Expired 01 February 2007 8.7 Patch 5 x86, IA64, AMD64, EM64T Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003 MS SDK, Intel C/C++ 8.0

MKS Toolkit for System Administrators

Version Support Expires Current Patch Platforms Certified OSs
9.4† Support Expired 14 May 2010 9.4 Patch 1 x86, IA64, AMD64 Windows 7, 2000, XP Home, XP Pro, XP x64, Server 2003, Server 2003 x64, Server 2003 R2, Server 2003 R2 x64,Server 2003 for Itanium, Server 2008 R2 (32-bit and x64), Server 2008 R2 for Itanium, Vista
9.3 Support Expired 14 May 2010 (early release of 9.4) none x86, IA64, AMD64 Windows 7, 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista
9.2 Support Expired 31 January 2013 9.2 Patch 3 x86, IA64, AMD64 2000, XP Home, XP Pro, Server 2003, Server 2008, Vista
9.1 Support Expired 04 February 2010 9.1 Patch 1 x86, IA64, AMD64 2000, XP Home, XP Pro, Server 2003, Vista
9.0 Support Expired 10 July 2008 9.0 Patch 5 x86, IA64, AMD64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003
8.7 Support Expired 01 February 2007 8.7 Patch 5 x86, IA64, AMD64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003
8.6 Support Expired 01 June 2005 8.6 Patch 3 x86, IA64 Windows Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003
8.5 Support Expired 01 Nov 2004 8.5 Patch 2 x86, IA64 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro, Server 2003
8.1 Support Expired 30 Nov 2003 8.1 Patch 3 x86, IA64 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro
8.0 Support Expired 30 Sep 2003 8.0 Patch 1 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000, XP Home, XP Pro
7.5 Support Expired 31 January 2003 7.5 Patch 1 x86 Windows 9x, Me, NT 4.0, NT 4.0 TSE, 2000
7.0.1 Support Expired 31 January 2002 none x86 Windows 9x, NT 4.0, NT 4.0 TSE, 2000
7.0 Support Expired 31 January 2002 7.0 Patch 1 x86 Windows 9x, NT 4.0, NT 4.0 TSE, 2000

† Effective March 1, 2011, we discontinued the sale and/or update of licenses of our MKS Toolkit for System Administrators product. All MKS Toolkit for System Administrative licenses with a current PCS support contract are eligible to be updated to PTC MKS Toolkit for Developers free of charge.

MKS AlertCentre

Version Support Expires Current Patch Platforms Certified OSs Certified Browsers
2.04† EOL 01 Nov 2005 2.04 x86, IA64, x64 Windows NT 4.0, NT 4.0 TSE, 2000, XP Pro, Server 2003 IE 5.5+, NS 6.0+, Mozilla 1.0+
2.03* EOL 01 Nov 2005 2.03 x86, IA64, x64 Windows NT 4.0, NT 4.0 TSE, 2000, XP Pro, Server 2003 IE 5.5+, NS 6.0+, Mozilla 1.0+
2.0 EOL 01 Nov 2005 2.02 x86, IA64 Windows NT 4.0, NT 4.0 TSE, 2000, XP Pro, Server 2003 IE 5.5+, NS 6.0+, Mozilla 1.0+
1.0** Support Expired 30 Nov 2003 8.1 Patch 2*** x86, IA64 Windows NT 4.0, NT 4.0 TSE, 2000, XP Pro IE 5.5+, NS 6.0+, Mozilla 1.0+

† AlertCentre 2.04 is a free add-on to any MKS Toolkit product (requires 9.0 patch 2 or above).
* AlertCentre 2.03 is a free add-on to any MKS Toolkit product (requires 8.7 patch 3 or above).
** AlertCentre 1.0 bundled as part of MKS Toolkit for System Administrators with AlertCentre 8.1, or was sold as an Add-On.
*** AlertCentre 1.0 Patch 1 included in MKS Toolkit 8.1 Patch 2